PHP 7.3.x < 7.3.17 Multiple Vulnerabilities

high Web Application Scanning Plugin ID 112498


PHP 7.3.x < 7.3.17 Multiple Vulnerabilities


According to its banner, the version of PHP running on the remote web server is prior to 7.2.30, 7.3.x prior to 7.3.17, or 7.4.x prior to 7.4.5. It is, therefore, affected by multiple vulnerabilities:

- An out-of-bounds read error exists in urldecode() due to improper data validation checks. An attacker can exploit this, by inserting negative hex values to leak values that are found in the memory before the array. (CVE-2020-7067)

- A NULL byte injection vulnerability exists in shell_exec() and the backtick operator due to improper data sanitization.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.3.17 or later.

See Also

Plugin Details

Severity: High

ID: 112498

Type: remote

Published: 6/26/2020

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2020-7067


Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N


Risk Factor: High

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/27/2020

Vulnerability Publication Date: 4/27/2020

Reference Information

CVE: CVE-2020-7067