Oracle MySQL 5.7.x < 5.7.14 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9617

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.7.x prior to 5.7.14 and is affected by multiple issues :

- A flaw exists in InnoDB that is triggered when selecting full-text index information schema tables for a deleted table. This may allow an authenticated attacker to crash the database.
- A flaw exists in InnoDB that is triggered during the handling of 'ALTER TABLE' operations on a table with an indexed virtual column. This may allow an authenticated attacker to crash the database.
- A flaw exists in a library used by MySQL. Specifically, the Henry Spencer regex Library (rxspencer) contains an overflow condition that is triggered as certain input is not properly validated. This may allow a context-dependent attacker to cause a buffer overflow, resulting in an unspecified impact that may include a denial of service in a process linked against the library or potentially allow the execution of arbitrary code.
- An unspecified flaw exists related to the DML subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the InnoDB subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Memcached subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Performance Schema subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the RBR subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Security:Audit subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor.
- An unspecified flaw exists related to the Replication subcomponent. This may allow a context-dependent attacker to cause a denial of service. No further details have been provided by the vendor.

Solution

Upgrade to MySQL 5.7.14 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-14.html

Plugin Details

Severity: High

ID: 9617

Family: Database

Published: 2016/09/30

Updated: 2019/03/06

Dependencies: 8914

Nessus ID: 93004, 93005

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2016/07/29

Vulnerability Publication Date: 2016/07/29

Reference Information

CVE: CVE-2016-3495, CVE-2016-5609, CVE-2016-5612, CVE-2016-5627, CVE-2016-5628, CVE-2016-5630, CVE-2016-5631, CVE-2016-5633, CVE-2016-5634, CVE-2016-5635, CVE-2016-8284, CVE-2016-8287, CVE-2016-8289, CVE-2016-8290

BID: 93622, 93642, 93662, 93670, 93674, 93684, 93702, 93727, 93733, 93755