MySQL 5.7.x < 5.7.14 Multiple Vulnerabilities

Medium Nessus Plugin ID 93004

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL running on the remote host is 5.7.x prior to 5.7.14. It is, therefore, affected by multiple vulnerabilities :

- Multiple unspecified flaws exist in the InnoDB subcomponent that allow an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-3495, CVE-2016-5627, CVE-2016-5630)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-5612)

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-5628)

- An unspecified flaw exists in the Memcached subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-5631)

- Multiple unspecified flaws exist in the Performance Schema subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-5633, CVE-2016-8290)

- An unspecified flaw exists in the RBR subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-5634)

- An unspecified flaw exists in the Security: Audit subcomponent that allows an authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-5635)

- An unspecified flaw exists in the Replication subcomponent that allows a local attacker to cause a denial of service condition. (CVE-2016-8284)

- An unspecified flaw exists in the Replication subcomponent that allows a authenticated, remote attacker to cause a denial of service condition.
(CVE-2016-8287)

- An unspecified flaw exists in the InnoDB subcomponent that allows a local attacker to impact integrity and availability. (CVE-2016-8289)

- A denial of service vulnerability exists in InnoDB when selecting full-text index information schema tables for a deleted table. An authenticated, remote attacker can exploit this to cause a segmentation fault.

- A denial of service vulnerability exists in InnoDB when handling ALTER TABLE operations on tables that have an indexed virtual column. An authenticated, remote attacker can exploit this to cause an assertion failure, resulting in a server crash.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.7.14 or later.

See Also

http://www.nessus.org/u?bac902d5

https://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-14.html

Plugin Details

Severity: Medium

ID: 93004

File Name: mysql_5_7_14.nasl

Version: 1.11

Type: remote

Family: Databases

Published: 2016/08/17

Updated: 2019/01/02

Dependencies: 91823, 10719

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/07/29

Vulnerability Publication Date: 2016/07/29

Reference Information

CVE: CVE-2016-3495, CVE-2016-5612, CVE-2016-5627, CVE-2016-5628, CVE-2016-5630, CVE-2016-5631, CVE-2016-5633, CVE-2016-5634, CVE-2016-5635, CVE-2016-8284, CVE-2016-8287, CVE-2016-8289, CVE-2016-8290

BID: 93630, 93642, 93662, 93670, 93674, 93684, 93702, 93709, 93715, 93720, 93727, 93733, 93755