OpenSSL 1.0.1 < 1.0.1r / 1.0.2 < 1.0.2f Information Disclosure

low Nessus Network Monitor Plugin ID 9464
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote web server is running an outdated instance of OpenSSL and that is affected by an Information Disclosure vulnerability.

Description

According to its banner, the version of OpenSSL on the remote host is 1.0.2 prior to 1.0.2f or 1.0.1 prior to 1.0.1r and is affected by a flaw that is triggered when handling cipher negotiation. This may allow a remote attacker to negotiate SSLv2 ciphers that are disabled on the server.

Solution

Upgrade OpenSSL to version 1.0.2f or higher. If 1.0.2 cannot be obtained, 1.0.1r has also been patched for this vulnerability.

See Also

https://www.openssl.org/news/secadv/20160128.txt

Plugin Details

Severity: Low

ID: 9464

Family: Web Servers

Published: 8/5/2016

Updated: 3/6/2019

Dependencies: 5563

Nessus ID: 92185, 92158, 91751, 91154

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*

Patch Publication Date: 1/28/2015

Vulnerability Publication Date: 1/28/2015

Reference Information

CVE: CVE-2015-3197

BID: 82237