SynopsisThe remote host is running an outdated version of Adobe Flash Player that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash Player prior to 184.108.40.2061, 220.127.116.112, or 18.104.22.168 are outdated and thus unpatched for the following vulnerabilities :
- Multiple type confusion errors exist that allow an attacker to execute arbitrary code. (CVE-2016-1105, CVE-2016-4117)
- Multiple use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2016-1097, CVE-2016-1106, CVE-2016-1107, CVE-2016-1108, CVE-2016-1109, CVE-2016-1110, CVE-2016-4108, CVE-2016-4110, CVE-2016-4121)
- A heap buffer overflow condition exists that allows an attacker to execute arbitrary code. (CVE-2016-1101)
- An unspecified buffer overflow exists that allows an attacker to execute arbitrary code. (CVE-2016-1103)
- Multiple memory corruption issues exist that allow an attacker to execute arbitrary code. (CVE-2016-1096, CVE-2016-1098, CVE-2016-1099, CVE-2016-1100, CVE-2016-1102, CVE-2016-1104, CVE-2016-4109, CVE-2016-4111, CVE-2016-4112, CVE-2016-4113, CVE-2016-4114, CVE-2016-4115, CVE-2016-4120, CVE-2016-4160, CVE-2016-4161, CVE-2016-4162, CVE-2016-4163)
- A flaw exists when loading dynamic-link libraries. An attacker can exploit this, via a specially crafted '.dll' file, to execute arbitrary code. (CVE-2016-4116)
SolutionUpgrade to Adobe Flash Player version 22.214.171.124 or later. If 21.x cannot be obtained, versions 126.96.36.1992 and 188.8.131.521 have also been patched for these vulnerabilities.