Adobe Flash Player <= 22.214.171.124 Multiple Vulnerabilities (APSB16-15)
High Nessus Plugin ID 91163
SynopsisThe remote Windows host has a browser plugin installed that is affected by multiple vulnerabilities.
DescriptionThe version of Adobe Flash Player installed on the remote Windows host is equal or prior to 126.96.36.199. It is, therefore, affected by multiple vulnerabilities :
- Multiple type confusion errors exist that allow an attacker to execute arbitrary code. (CVE-2016-1105, CVE-2016-4117)
- Multiple use-after-free errors exist that allow an attacker to execute arbitrary code. (CVE-2016-1097, CVE-2016-1106, CVE-2016-1107, CVE-2016-1108, CVE-2016-1109, CVE-2016-1110, CVE-2016-4108, CVE-2016-4110, CVE-2016-4121)
- A heap buffer overflow condition exists that allows an attacker to execute arbitrary code. (CVE-2016-1101)
- An unspecified buffer overflow exists that allows an attacker to execute arbitrary code. (CVE-2016-1103)
- Multiple memory corruption issues exist that allow an attacker to execute arbitrary code. (CVE-2016-1096, CVE-2016-1098, CVE-2016-1099, CVE-2016-1100, CVE-2016-1102, CVE-2016-1104, CVE-2016-4109, CVE-2016-4111, CVE-2016-4112, CVE-2016-4113, CVE-2016-4114, CVE-2016-4115, CVE-2016-4120, CVE-2016-4160, CVE-2016-4161, CVE-2016-4162, CVE-2016-4163)
- A flaw exists when loading dynamic-link libraries. An attacker can exploit this, via a specially crafted .dll file, to execute arbitrary code. (CVE-2016-4116)
SolutionUpgrade to Adobe Flash Player version 188.8.131.52 or later.
Alternatively, Adobe has made version 184.108.40.2062 available for those installations that cannot be upgraded to the latest version.