VLC Media Player < 2.1.5 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9265

Synopsis

The remote host contains a media application that is affected by two memory corruption vulnerabilities.

Description

The remote host is running VLC 2.x prior to 2.1.5 and is affected by multiple vulnerabilities :

- An error exists in the 'png_push_read_chunk()' function within the file 'pngpread.c' from the included libpng library that can allow denial of service attacks. (CVE-2014-0333)
- A buffer overflow error exists in the 'read_server_hello()' function within the file 'lib/gnutls_handshake.c' from the included GnuTLS library that can allow arbitrary code execution or denial of service. (CVE-2014-3466)
- A heap-based buffer overflow error exists in the transcode module due to improper validation of user-supplied input when handling invalid channel counts. An attacker can exploit this to execute arbitrary code. (CVE-2014-6440)

Solution

Upgrade to VLC Media Player version 2.1.5 or later.

See Also

http://www.videolan.org/developers/vlc-branch/NEWS

http://www.videolan.org/vlc/releases/2.1.5.html

Plugin Details

Severity: Medium

ID: 9265

File Name: 9265.prm

Family: Web Clients

Published: 2015/03/22

Modified: 2016/12/06

Dependencies: 9797

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Patch Publication Date: 2015/01/20

Vulnerability Publication Date: 2015/01/20

Reference Information

CVE: CVE-2014-0333, CVE-2014-3466, CVE-2014-6440

BID: 65776, 67741, 72950