CVE-2014-6440

critical
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

VideoLAN VLC media player before 2.1.5 allows remote attackers to execute arbitrary code or cause a denial of service.

References

http://billblough.net/blog/2015/03/04/cve-2014-6440-heap-overflow-in-vlc-transcode-module/

http://seclists.org/oss-sec/2015/q1/751

http://www.securityfocus.com/bid/72950

http://www.videolan.org/developers/vlc-branch/NEWS

https://security.gentoo.org/glsa/201603-08

Details

Source: MITRE

Published: 2017-03-28

Updated: 2017-04-03

Type: CWE-119

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

CVSS v3

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Impact Score: 5.9

Exploitability Score: 3.9

Severity: CRITICAL

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:videolan:vlc:*:*:*:*:*:*:*:* versions up to 2.1.4 (inclusive)

Tenable Plugins

View all (3 total)

IDNameProductFamilySeverity
89901GLSA-201603-08 : VLC: Multiple vulnerabilitiesNessusGentoo Local Security Checks
critical
9265VLC Media Player < 2.1.5 Multiple VulnerabilitiesNessus Network MonitorWeb Clients
medium
78626VLC Media Player < 2.1.5 Multiple VulnerabilitiesNessusWindows
critical