VLC Media Player < 2.1.5 Multiple Vulnerabilities

Medium Nessus Plugin ID 78626


The remote Windows host contains a media player that is affected by multiple vulnerabilities.


The version of VLC media player installed on the remote host is prior to 2.1.5. It is, therefore, affected by the following vulnerabilities :

- An error exists in the png_push_read_chunk() function within the file 'pngpread.c' from the included libpng library that can allow denial of service attacks.

- A buffer overflow error exists in the read_server_hello() function within the file 'lib/gnutls_handshake.c' from the included GnuTLS library that can allow arbitrary code execution or denial of service. (CVE-2014-3466)

- A heap-based buffer overflow error exists in the transcode module due to improper validation of user-supplied input when handling invalid channel counts. An attacker can exploit this to execute arbitrary code. (CVE-2014-6440)


Upgrade to version 2.1.5 or later.

See Also



Plugin Details

Severity: Medium

ID: 78626

File Name: vlc_2_1_5.nasl

Version: $Revision: 1.2 $

Type: local

Agent: windows

Family: Windows

Published: 2014/10/22

Modified: 2015/03/05

Dependencies: 31852

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: installed_sw/VLC media player

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/07/26

Vulnerability Publication Date: 2014/02/25

Reference Information

CVE: CVE-2014-0333, CVE-2014-3466, CVE-2014-6440

BID: 65776, 67741, 72950

OSVDB: 103695, 107564, 119111

CERT: 684412