PostgreSQL 9.1 < 9.1.20 / 9.2 < 9.2.15 / 9.3 < 9.3.11 / 9.4 < 9.4.6 / 9.5 < 9.5.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9264

Synopsis

The database running on the remote server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.20, 9.2.x prior to 9.2.15, 9.3.x prior to 9.3.11, or 9.4.x prior to 9.4.6, or 9.5.x prior to 9.5.1 and is affected by multiple vulnerabilities :

- An integer overflow condition exists that is triggered as user-supplied input is not properly validated when handling regular expressions. This may allow an attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (OSVDB 134458)
- A flaw exists in the 'init_custom_variable()' function in 'backend/utils/misc/guc.c' that is triggered during the handling of PL/Java. This may allow an attacker to gain elevated privileges. (OSVDB 134459)
- A flaw exists related to certain security definer functions or when a common user and query is planned initially and reused across multiple SET ROLEs. This may allow an authenticated attacker to cause incorrect policies to be applied in cases where role-specific polices are used. (OSVDB 136561)
- A flaw exists in 'contrib/pageinspect/brinfuncs.c' that is triggered during the use of pageinspect functions on BRIN index pages. This may allow an authenticated attacker to cause a crash or gain access to a small amount of server memory information, which may potentially contain credential information. (OSVDB 136562)

Solution

Upgrade to PostgreSQL 9.1.20 / 9.2.15 / 9.3.11 / 9.4.6 / 9.5.1, or later.

See Also

http://www.postgresql.org/about/news/1644

http://www.postgresql.org/docs/9.1/static/release-9-1-20.html

http://www.postgresql.org/docs/9.2/static/release-9-2-15.html

http://www.postgresql.org/docs/9.3/static/release-9-3-11.html

http://www.postgresql.org/docs/9.4/static/release-9-4-6.html

http://www.postgresql.org/docs/9.5/static/release-9-5-1.html

Plugin Details

Severity: High

ID: 9264

Family: Database

Published: 2016/04/22

Modified: 2016/04/22

Dependencies: 8705

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.7

Temporal Score: 8.3

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2016/02/08

Vulnerability Publication Date: 2016/02/08

Reference Information

CVE: CVE-2016-0766, CVE-2016-0773, CVE-2016-2193, CVE-2016-3065

BID: 83184