PostgreSQL 9.1 < 9.1.20 / 9.2 < 9.2.15 / 9.3 < 9.3.11 / 9.4 < 9.4.6 / 9.5 < 9.5.1 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 9264


The database running on the remote server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.20, 9.2.x prior to 9.2.15, 9.3.x prior to 9.3.11, or 9.4.x prior to 9.4.6, or 9.5.x prior to 9.5.1 and is affected by multiple vulnerabilities :

- An integer overflow condition exists that is triggered as user-supplied input is not properly validated when handling regular expressions. This may allow an attacker to cause a heap-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code.
- A flaw exists in the 'init_custom_variable()' function in 'backend/utils/misc/guc.c' that is triggered during the handling of PL/Java. This may allow an attacker to gain elevated privileges.
- A flaw exists related to certain security definer functions or when a common user and query is planned initially and reused across multiple SET ROLEs. This may allow an authenticated attacker to cause incorrect policies to be applied in cases where role-specific polices are used.
- A flaw exists in 'contrib/pageinspect/brinfuncs.c' that is triggered during the use of pageinspect functions on BRIN index pages. This may allow an authenticated attacker to cause a crash or gain access to a small amount of server memory information, which may potentially contain credential information.


Upgrade to PostgreSQL 9.1.20 / 9.2.15 / 9.3.11 / 9.4.6 / 9.5.1, or later.

See Also

Plugin Details

Severity: High

ID: 9264

Family: Database

Published: 4/22/2016

Updated: 3/6/2019

Risk Information


Risk Factor: High

Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Risk Factor: High

Base Score: 8.8

Temporal Score: 8.4

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*

Patch Publication Date: 2/8/2016

Vulnerability Publication Date: 2/8/2016

Reference Information

CVE: CVE-2016-0766, CVE-2016-0773, CVE-2016-3065, CVE-2016-2193

BID: 83184