Oracle MySQL 5.5.x < 5.5.46 / 5.6.x < 5.6.27 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9252

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.46 or 5.6.x prior to 5.6.27 and is affected by vulnerabilities in the following components :

- :

- Client Programs
- Data Definition Language
- Data Manipulation Language
- InnoDB
- Option
- Partition
- Query Cache
- Security:Privileges
- Server Parser
- Server Partition
- Stored Procedures
- Types

Solution

Upgrade to MySQL 5.6.27 or later. If 5.6.x cannot be obtained, version 5.5.46 is also patched for these issues.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-46.html

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-27.html

Plugin Details

Severity: High

ID: 9252

Family: Database

Published: 2016/04/15

Updated: 2019/03/06

Dependencies: 8914

Nessus ID: 86546, 86547

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 8.4

Temporal Score: 8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/10/20

Vulnerability Publication Date: 2015/10/20

Reference Information

CVE: CVE-2015-4792, CVE-2015-4802, CVE-2015-4807, CVE-2015-4815, CVE-2015-4816, CVE-2015-4819, CVE-2015-4826, CVE-2015-4830, CVE-2015-4836, CVE-2015-4858, CVE-2015-4861, CVE-2015-4864, CVE-2015-4870, CVE-2015-4879, CVE-2015-4913, CVE-2016-3471