PHP 5.4.x < 5.4.28 / 5.5.x < 5.5.12 Privilege Escalation

medium Nessus Network Monitor Plugin ID 9096
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is affected by a privilege escalation vulnerability.


Versions of PHP 5.4.x earlier than 5.4.28, or 5.5.x earlier than 5.5.12 are exposed to a flaw that exists within the FastCGI Process Manager (FPM) when setting permissions for a Unix socket. This could allow a remote attacker to gain elevated privileges after gaining access to the socket.


Apply the vendor patch or upgrade to PHP version 5.5.12 or later. If 5.5.x cannot be installed, 5.4.28 is also patched for these vulnerabilities.

See Also

Plugin Details

Severity: Medium

ID: 9096

Family: Web Servers

Published: 2/25/2015

Updated: 3/6/2019

Dependencies: 8682

Nessus ID: 73862, 73863

Risk Information


Risk Factor: Medium

Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.9

Temporal Score: 5.7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 5/1/2014

Vulnerability Publication Date: 4/12/2014

Reference Information

CVE: CVE-2014-0185

BID: 67118