PHP 5.4.x < 5.4.28 / 5.5.x < 5.5.12 Privilege Escalation

Medium Nessus Network Monitor Plugin ID 9096

Synopsis

The remote web server uses a version of PHP that is affected by a privilege escalation vulnerability.

Description

Versions of PHP 5.4.x earlier than 5.4.28, or 5.5.x earlier than 5.5.12 are exposed to a flaw that exists within the FastCGI Process Manager (FPM) when setting permissions for a Unix socket. This could allow a remote attacker to gain elevated privileges after gaining access to the socket.

Solution

Apply the vendor patch or upgrade to PHP version 5.5.12 or later. If 5.5.x cannot be installed, 5.4.28 is also patched for these vulnerabilities.

See Also

https://bugs.php.net/bug.php?id=67060

http://www.php.net/ChangeLog-5.php#5.5.12

http://www.php.net/ChangeLog-5.php#5.4.28

http://www.nessus.org/u?a7b8dfdd

Plugin Details

Severity: Medium

ID: 9096

Family: Web Servers

Published: 2015/02/25

Modified: 2016/02/25

Dependencies: 8682

Nessus ID: 73862, 73863

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.9

Temporal Score: 5.6

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2014/05/01

Vulnerability Publication Date: 2014/04/12

Reference Information

CVE: CVE-2014-0185

BID: 67118