PHP 5.5.x < 5.5.12 FPM Unix Socket Insecure Permission Escalation

High Nessus Plugin ID 73863

Synopsis

The remote web server uses a version of PHP that is potentially affected by a permission escalation vulnerability.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.12. It is, therefore, potentially affected by a permission escalation vulnerability.

A flaw exists within the FastCGI Process Manager (FPM) when setting permissions for a Unix socket. This could allow a remote attacker to gain elevated privileges after gaining access to the socket.

Note that this plugin has not attempted to exploit this issue, but instead relied only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.5.12 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.5.12

https://bugs.php.net/bug.php?id=67060

http://www.nessus.org/u?a7b8dfdd

Plugin Details

Severity: High

ID: 73863

File Name: php_5_5_12.nasl

Version: 1.10

Type: remote

Family: CGI abuses

Published: 2014/05/05

Updated: 2018/09/17

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2014-0185

CVSS v2.0

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/05/01

Vulnerability Publication Date: 2014/04/12

Reference Information

CVE: CVE-2014-0185

BID: 67118