PHP 5.4.x < 5.4.28 FPM Unix Socket Insecure Permission Escalation

high Nessus Plugin ID 73862


The remote web server uses a version of PHP that is potentially affected by a permission escalation vulnerability.


According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.28. It is, therefore, potentially affected by a permission escalation vulnerability.

A flaw exists within the FastCGI Process Manager (FPM) when setting permissions for a Unix socket. This could allow a remote attacker to gain elevated privileges after gaining access to the socket.

Note that this plugin has not attempted to exploit this issue, but instead relied only on PHP's self-reported version number.


Upgrade to PHP version 5.4.28 or later.

See Also

Plugin Details

Severity: High

ID: 73862

File Name: php_5_4_28.nasl

Version: 1.11

Type: remote

Family: CGI abuses

Published: 5/5/2014

Updated: 5/28/2024

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: High

Base Score: 7.2

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS Score Source: CVE-2014-0185

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Excluded KB Items: Settings/disable_cgi_scanning

Exploit Ease: No exploit is required

Patch Publication Date: 5/1/2014

Vulnerability Publication Date: 4/12/2014

Reference Information

CVE: CVE-2014-0185

BID: 67118