Flash Player < 13.0.0.296 / 18.0.0.194 RCE (APSB15-14)

High Nessus Network Monitor Plugin ID 8820

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by a remote code execution vulnerability.

Description

Versions of Adobe Flash Player prior to 18.0.0.194 are outdated and thus unpatched for a remote code execution vulnerability due to improper validation of unspecified user-supplied input. A remote attacker can exploit this, via specially crafted Flash content, to cause a heap-based buffer overflow, resulting in the execution of arbitrary code.

Solution

Upgrade to Adobe Flash Player version 18.0.0.194 or later. If 18.x cannot be obtained, 13.0.0.296 has also been patched for these vulnerabilities.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-14.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 8820

Family: Web Clients

Published: 2015/07/24

Modified: 2016/11/23

Dependencies: 5158

Nessus ID: 84365, 84366

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2015/06/23

Vulnerability Publication Date: 2015/06/23

Exploitable With

Core Impact

Metasploit (Adobe Flash Player Nellymoser Audio Decoding Buffer Overflow)

Reference Information

CVE: CVE-2015-3113

IAVA: 2015-A-0132