Adobe Flash Player <= 18.0.0.161 RCE (APSB15-14) (Mac OS X)

High Nessus Plugin ID 84366

Synopsis

The remote Mac OS X host has a browser plugin installed that is affected by a remote code execution vulnerability.

Description

The version of Adobe Flash Player installed on the remote Mac OS X host is equal or prior to version 18.0.0.161. It is, therefore, affected by a remote code execution vulnerability due to improper validation of unspecified user-supplied input. A remote attacker can exploit this, via specially crafted Flash content, to cause a heap-based buffer overflow, resulting in the execution of arbitrary code.

Solution

Upgrade to Adobe Flash Player version 18.0.0.194 or later.

Alternatively, Adobe has made version 13.0.0.296 available for those installations that cannot be upgraded to 18.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-14.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 84366

File Name: macosx_flash_player_apsb15-14.nasl

Version: 1.10

Type: local

Agent: macosx

Published: 2015/06/24

Updated: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/23

Vulnerability Publication Date: 2015/06/23

Exploitable With

Core Impact

Metasploit (Adobe Flash Player Nellymoser Audio Decoding Buffer Overflow)

Reference Information

CVE: CVE-2015-3113