Adobe Flash Player <= 18.0.0.161 RCE (APSB15-14)

High Nessus Plugin ID 84365

Synopsis

The remote Windows host has a browser plugin installed that is affected by a remote code execution vulnerability.

Description

The version of Adobe Flash Player installed on the remote Windows host is equal or prior to version 18.0.0.161. It is, therefore, affected by a remote code execution vulnerability due to improper validation of unspecified user-supplied input. A remote attacker can exploit this, via specially crafted Flash content, to cause a heap-based buffer overflow, resulting in the execution of arbitrary code.

Solution

Upgrade to Adobe Flash Player version 18.0.0.194 or later.

Alternatively, Adobe has made version 13.0.0.296 available for those installations that cannot be upgraded to 18.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb15-14.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 84365

File Name: flash_player_apsb15-14.nasl

Version: 1.11

Type: local

Agent: windows

Family: Windows

Published: 2015/06/24

Updated: 2018/07/11

Dependencies: 28211

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: SMB/Flash_Player/installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2015/06/23

Vulnerability Publication Date: 2015/06/23

Exploitable With

Core Impact

Metasploit (Adobe Flash Player Nellymoser Audio Decoding Buffer Overflow)

Reference Information

CVE: CVE-2015-3113