phpMyAdmin 4.0.x < 4.0.10.1 / 4.1.x < 4.1.14.2 / 4.2.x < 4.2.6 Multiple Vulnerabilities (PMASA-2014-4 through PMASA-2014-7)

Medium Nessus Network Monitor Plugin ID 8377

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin earlier than 4.0.10.1, 4.1.14.2, or 4.2.6 are unpatched for the following vulnerabilities :

- The 'TABLE_COMMENT' parameter input is not being validated in the script 'libraries/structure.lib.php' and could allow cross-site scripting attacks. Note that this issue affects the 4.2.x branch. (CVE-2014-4954)

- The 'trigger' parameter input is not being validated in the script 'libraries/rte/rte_list.lib.php' and could allow cross-site scripting attacks. (CVE-2014-4955)

- The 'table' and 'curr_column_name' parameter inputs are not being validated in the scripts 'js/functions.js' and 'js/tbl_structure.js' respectively and could allow cross-site scripting attacks. (CVE-2014-4986)

- The script 'server_user_groups.php' contains an error that could allow a remote attacker to obtain the MySQL user list and possibly make changes to the application display. Note this issue only affects the 4.1.x and 4.2.x branches. (CVE-2014-4987)

Solution

Either upgrade to phpMyAdmin 4.0.10.1, 4.1.14.2, 4.2.6 or later, or apply the patches from the referenced links.

See Also

http://www.phpmyadmin.net/home_page/security/PMASA-2014-4.php

http://www.phpmyadmin.net/home_page/security/PMASA-2014-5.php

http://www.phpmyadmin.net/home_page/security/PMASA-2014-6.php

http://www.phpmyadmin.net/home_page/security/PMASA-2014-7.php

Plugin Details

Severity: Medium

ID: 8377

Family: CGI

Published: 2014/10/02

Modified: 2016/02/29

Dependencies: 9102

Nessus ID: 76915

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2014/07/22

Vulnerability Publication Date: 2014/07/22

Reference Information

CVE: CVE-2014-4954, CVE-2014-4955, CVE-2014-4986, CVE-2014-4987

BID: 68798, 68799, 68803, 68804