phpMyAdmin 4.0.x < / 4.1.x < / 4.2.x < 4.2.6 Multiple Vulnerabilities (PMASA-2014-4 - PMASA-2014-7)

Medium Nessus Plugin ID 76915


The remote web server hosts a PHP application that is affected by multiple vulnerabilities.


According to its self-reported version number, the phpMyAdmin install hosted on the remote web server is 4.0.x prior to, 4.1.x prior to, or 4.2.x prior to 4.2.6. It is, therefore, affected by the following vulnerabilities :

- The 'TABLE_COMMENT' parameter input is not being validated in the script 'libraries/structure.lib.php' and could allow cross-site scripting attacks. Note that this issue affects the 4.2.x branch. (CVE-2014-4954)

- The 'trigger' parameter input is not being validated in the script 'libraries/rte/rte_list.lib.php' and could allow cross-site scripting attacks. (CVE-2014-4955)

- The 'table' and 'curr_column_name' parameter inputs are not being validated in the scripts 'js/functions.js' and 'js/tbl_structure.js' respectively and could allow cross-site scripting attacks. (CVE-2014-4986)

- The script 'server_user_groups.php' contains an error that could allow a remote attacker to obtain the MySQL user list and possibly make changes to the application display. Note this issue only affects the 4.1.x and 4.2.x branches. (CVE-2014-4987)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Either upgrade to phpMyAdmin / / 4.2.6 or later, or apply the patches from the referenced links.

See Also

Plugin Details

Severity: Medium

ID: 76915

File Name: phpmyadmin_pmasa_2014_7.nasl

Version: 1.5

Type: remote

Family: CGI abuses

Published: 2014/07/30

Updated: 2018/11/15

Dependencies: 17219

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Required KB Items: www/PHP, www/phpMyAdmin, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/07/17

Vulnerability Publication Date: 2014/07/17

Reference Information

CVE: CVE-2014-4954, CVE-2014-4955, CVE-2014-4986, CVE-2014-4987

BID: 68798, 68799, 68803, 68804

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990