Safari < 6.1.2 / 7.0.2 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 8137
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple security vulnerabilities.

Description

The remote host has Safari installed that is older than 6.1.2 or 7.0.2, which means it is not patched for the following WebKit vulnerabilities :

- Unspecified memory-corruption vulnerabilities that could be leveraged to execute arbitrary code, or cause denial of service. (CVE-2014-1268, CVE-2014-1269, CVE-2014-1270)
- Use-after-free error in the 'ReplaceSelectionCommand' file which can be leveraged to execute arbitrary code, or cause denial of service (CVE-2013-6635)

Solution

OS X Mavericks (v10.9) users should upgrade to 10.9.2, which includes the Safari 7.0.2 update. All others should upgrade to Safari 6.1.2 or later.

See Also

http://support.apple.com/kb/HT6145

http://lists.apple.com/archives/security-announce/2014/Feb/msg00001.html

Plugin Details

Severity: Medium

ID: 8137

Family: Web Clients

Published: 2/26/2014

Updated: 3/6/2019

Dependencies: 3705

Nessus ID: 72689

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*

Patch Publication Date: 2/25/2013

Vulnerability Publication Date: 2/25/2014

Reference Information

CVE: CVE-2014-1268, CVE-2014-1269, CVE-2014-1270, CVE-2013-6635

BID: 65781, 65780, 65779, 65778