Mac OS X : Apple Safari < 6.1.2 / 7.0.2 Multiple Memory Corruption Vulnerabilities

medium Nessus Plugin ID 72689
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by multiple memory corruption vulnerabilities.

Description

The version of Apple Safari installed on the remote Mac OS X host is a version prior to 6.1.2 or 7.0.2. It is, therefore, potentially affected by multiple, unspecified, memory corruption vulnerabilities in WebKit that could lead to unexpected program termination or arbitrary code execution.

Solution

For Mac OS X 10.9, upgrade to 10.9.2, which includes Apple Safari 7.0.2. Otherwise, upgrade to Apple Safari 6.1.2.

See Also

http://support.apple.com/kb/HT6145

http://lists.apple.com/archives/security-announce/2014/Feb/msg00001.html

http://www.securityfocus.com/archive/1/531264/30/0/threaded

Plugin Details

Severity: Medium

ID: 72689

File Name: macosx_Safari7_0_2.nasl

Version: 1.6

Type: local

Agent: macosx

Published: 2/25/2014

Updated: 7/14/2018

Dependencies: macosx_Safari31.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 2/25/2014

Vulnerability Publication Date: 12/7/2013

Reference Information

CVE: CVE-2013-6635, CVE-2014-1268, CVE-2014-1269, CVE-2014-1270

BID: 65778, 65779, 65780, 65781

APPLE-SA: APPLE-SA-2014-02-25-2