OpenSSL < 0.9.8x / < 1.0.0j / < 1.0.1c Remote Denial of Service Vulnerability
Medium Nessus Network Monitor Plugin ID 8064
SynopsisThe remote web server is running an instance of OpenSSL that might be affected by a denial of service vulnerability.
DescriptionOpenSSL before 0.9.8x, 1.0.0.j, or 1.0.1c contains an integer underflow condition which may result in a denial of service. A remote attacker could send a specially crafted TLS request causing the affected application to crash causing denial of service to legitimate users. The integer underflow is seen in TLS 1.1, TLS 1.2, and DTLS when handling CBC mode ciphersuites.
SolutionUpgrade to OpenSSL version 0.9.8x or later, 1.0.0j or later, or 1.0.1c or later.