OpenSSL < 0.9.8x / < 1.0.0j / < 1.0.1c Remote Denial of Service Vulnerability

Medium Nessus Network Monitor Plugin ID 8064

Synopsis

The remote web server is running an instance of OpenSSL that might be affected by a denial of service vulnerability.

Description

OpenSSL before 0.9.8x, 1.0.0.j, or 1.0.1c contains an integer underflow condition which may result in a denial of service. A remote attacker could send a specially crafted TLS request causing the affected application to crash causing denial of service to legitimate users. The integer underflow is seen in TLS 1.1, TLS 1.2, and DTLS when handling CBC mode ciphersuites.

Solution

Upgrade to OpenSSL version 0.9.8x or later, 1.0.0j or later, or 1.0.1c or later.

See Also

http://www.openssl.org/news/secadv_20120510.txt

Plugin Details

Severity: Medium

ID: 8064

File Name: 8064.prm

Family: Web Servers

Published: 2013/12/06

Modified: 2016/01/30

Dependencies: 5563

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2012/05/10

Vulnerability Publication Date: 2012/05/10

Reference Information

CVE: CVE-2012-2333

BID: 53476

OSVDB: 81810