OpenSSL 0.9.8 < 0.9.8x DTLS CBC Denial of Service

Medium Nessus Plugin ID 59076


The remote host may be affected by a denial of service vulnerability.


According to its banner, the remote web server is running a version of OpenSSL 0.9.8 earlier than 0.9.8x. As such, the OpenSSL library itself is reportedly affected by a denial of service vulnerability.

An integer underflow error exists in the file 'ssl/d1_enc.c' in the function 'dtls1_enc'. When in CBC mode, DTLS record length values and explicit initialization vector length values related to DTLS packets are not handled properly, which can lead to memory corruption and application crashes.


Upgrade to OpenSSL 0.9.8x or later.

See Also

Plugin Details

Severity: Medium

ID: 59076

File Name: openssl_0_9_8x.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Web Servers

Published: 2012/05/11

Modified: 2017/06/12

Dependencies: 57323

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/10

Vulnerability Publication Date: 2012/05/10

Reference Information

CVE: CVE-2012-2333

BID: 53476

OSVDB: 81810