OpenSSL 1.0.1 < 1.0.1c TLS/DTLS CBC Denial of Service

Medium Nessus Plugin ID 59078


The remote host may be affected by a denial of service vulnerability.


According to its banner, the remote web server is running a version of OpenSSL 1.0.1 earlier than 1.0.1c. As such, the OpenSSL library itself is reportedly affected by a denial of service vulnerability.

An integer underflow error exists in the file 'ssl/d1_enc.c' in the function 'dtls1_enc'. When in CBC mode, TLS/DTLS record length values and explicit initialization vector length values related to TLS/DTLS packets are not handled properly, which can lead to memory corruption and application crashes.


Upgrade to OpenSSL 1.0.1c or later.

See Also

Plugin Details

Severity: Medium

ID: 59078

File Name: openssl_1_0_1c.nasl

Version: 1.8

Type: remote

Family: Web Servers

Published: 2012/05/11

Updated: 2018/11/15

Dependencies: 57323

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/05/10

Vulnerability Publication Date: 2012/05/10

Reference Information

CVE: CVE-2012-2333

BID: 53476