Apple Safari < 12.0.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 700507

Synopsis

A web browser installed on the remote host is affected by multiple vulnerabilities.

Description

The version of Apple Safari installed on the remote host is prior to 12.0.2. It is, therefore, affected by the following vulnerabilities :

- Input-validation errors exist that allow memory corruption leading to arbitrary code execution. (CVE-2018-4437, CVE-2018-4438, CVE-2018-4441, CVE-2018-4442, CVE-2018-4443, CVE-2018-4464)

Note that other flaws exist that allow information disclosure and address bar spoofing.

Solution

Upgrade to Apple Safari version 12.0.2 or later.

See Also

https://support.apple.com/en-us/HT209344

http://www.nessus.org/u?244b31ab

Plugin Details

Severity: High

ID: 700507

Family: Web Clients

Published: 2019/04/08

Updated: 2019/04/08

Dependencies: 3705

Nessus ID: 119498

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 8.8

Temporal Score: 7.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Patch Publication Date: 2018/12/05

Vulnerability Publication Date: 2018/12/05

Reference Information

CVE: CVE-2018-4437, CVE-2018-4438, CVE-2018-4439, CVE-2018-4440, CVE-2018-4441, CVE-2018-4442, CVE-2018-4443, CVE-2018-4445, CVE-2018-4464