macOS : Apple Safari < 12.0.2 Multiple Vulnerabilities

High Nessus Plugin ID 119498

Synopsis

A web browser installed on the remote macOS or Mac OS X host is affected by multiple vulnerabilities.

Description

The version of Apple Safari installed on the remote macOS or Mac OS X host is prior to 12.0.2. It is, therefore, affected by the following vulnerabilities :

- Input-validation errors exist that allow memory corruption leading to arbitrary code execution.
(CVE-2018-4437, CVE-2018-4438, CVE-2018-4441, CVE-2018-4442, CVE-2018-4443, CVE-2018-4464)

Note that other flaws exist that allow information disclosure and address bar spoofing.

Solution

Upgrade to Apple Safari version 12.0.2 or later.

See Also

https://support.apple.com/en-us/HT209344

http://www.nessus.org/u?244b31ab

Plugin Details

Severity: High

ID: 119498

File Name: macosx_Safari12_0_2.nasl

Version: 1.1

Type: local

Agent: macosx

Published: 2018/12/07

Modified: 2018/12/07

Dependencies: 31604

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-4437

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apple:safari, cpe:/o:apple:mac_os_x

Required KB Items: Host/local_checks_enabled, Host/MacOSX/Version, MacOSX/Safari/Installed

Patch Publication Date: 2018/12/05

Vulnerability Publication Date: 2018/12/05

Reference Information

CVE: CVE-2018-4437, CVE-2018-4438, CVE-2018-4439, CVE-2018-4440, CVE-2018-4441, CVE-2018-4442, CVE-2018-4443, CVE-2018-4445, CVE-2018-4464