Flash Player <= 10.3.183.90 / 11.7.700.225 Multiple Vulnerabilities (APSB13-17)

High Nessus Network Monitor Plugin ID 6922

Synopsis

The remote host contains a browser plug-in that is affected by multiple vulnerabilities.

Description

Versions of Flash 10.x equal or prior to 10.3.183.90, or 11.x equal or prior to 11.7.700.225, are potentially affected by the following vulnerabilities:

- A heap based buffer overflow vulnerability exists that could lead to code execution. (CVE-2013-3344)

- A memory corruption vulnerability exists that could lead to code execution. (CVE-2013-3345)

- An integer overflow exists when resampling a user-supplied PCM buffer. (CVE-2013-3347)

Solution

Upgrade to Flash Player 11.7.700.232 / 11.8.800.94 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb13-17.html

Plugin Details

Severity: High

ID: 6922

File Name: 6922.prm

Family: Web Clients

Published: 2013/07/11

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 67225, 67226

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2013/07/10

Vulnerability Publication Date: 2013/07/10

Reference Information

CVE: CVE-2013-3344, CVE-2013-3345, CVE-2013-3347

BID: 61043, 61045, 61048