PHP < 5.3.26 / 5.4.x < 5.4.16 Heap Based Buffer Overflow

Medium Nessus Network Monitor Plugin ID 6866

Synopsis

The remote web server uses a version of PHP that is affected by a heap-based buffer overflow vulnerability.

Description

PHP versions earlier than 5.4.16 and 5.3.26 are affected by a heap based buffer overflow vulnerability due to lack of user input sanitation when parsing strings. (An additional security vulnerability exists while parsing 'mimetype' for MP3 files, which can be exploited to cause a crash in version 5.4.15.)

Solution

Upgrade to PHP version 5.4.16 or 5.3.26, or later.

See Also

http://www.php.net/ChangeLog-5.php

http://www.php.net

Plugin Details

Severity: Medium

ID: 6866

Family: Web Servers

Published: 2013/06/07

Modified: 2016/01/19

Dependencies: 8682, 8728

Nessus ID: 66842, 66843

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2013/06/07

Vulnerability Publication Date: 2013/06/07

Reference Information

CVE: CVE-2013-2110, CVE-2013-4635, CVE-2013-4636

BID: 60411, 60728, 60731