PHP 5.4.x < 5.4.16 Multiple Vulnerabilities

Medium Nessus Plugin ID 66843

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 4.4


The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.


According to its banner, the version of PHP 5.4.x installed on the remote host is prior to 5.4.16. It is, therefore, potentially affected by the following vulnerabilities:

- An error exists in the mimetype detection of 'mp3' files that could lead to a denial of service. (Bug #64830)

- An error exists in the function 'php_quot_print_encode' in the file 'ext/standard/quot_print.c' that could allow a heap-based buffer overflow when attempting to parse certain strings. (Bug #64879)

- An integer overflow error exists related to the value of 'JEWISH_SDN_MAX' in the file 'ext/calendar/jewish.c' that could allow denial of service attacks. (Bug #64895)

Note that this plugin does not attempt to exploit these vulnerabilities, but instead relies only on PHP's self-reported version number.


Apply the vendor patch or upgrade to PHP version 5.4.16 or later.

See Also

Plugin Details

Severity: Medium

ID: 66843

File Name: php_5_4_16.nasl

Version: 1.16

Type: remote

Family: CGI abuses

Published: 2013/06/07

Updated: 2021/01/19

Dependencies: 48243

Risk Information

Risk Factor: Medium

VPR Score: 4.4

CVSS Score Source: CVE-2013-4635

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/06/06

Vulnerability Publication Date: 2013/05/22

Reference Information

CVE: CVE-2013-2110, CVE-2013-4635, CVE-2013-4636

BID: 60411, 60728, 60731