PHP 5.3.x < 5.3.26 Multiple Vulnerabilities

Medium Nessus Plugin ID 66842

Synopsis

The remote web server uses a version of PHP that is potentially
affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.3.x installed on the
remote host is prior to 5.3.26. It is, therefore, potentially affected
by the following vulnerabilities:

- An error exists in the function 'php_quot_print_encode'
in the file 'ext/standard/quot_print.c' that could allow
a heap-based buffer overflow when attempting to parse
certain strings (Bug #64879)

- An integer overflow error exists related to the value
of 'JEWISH_SDN_MAX' in the file 'ext/calendar/jewish.c'
that could allow denial of service attacks. (Bug #64895)

Note that this plugin does not attempt to exploit these
vulnerabilities, but instead relies only on PHP's self-reported
version number.

Solution

Apply the vendor patch or upgrade to PHP version 5.3.26 or later.

See Also

http://www.nessus.org/u?60cbc5f0

http://www.nessus.org/u?8456482e

http://www.php.net/ChangeLog-5.php#5.3.26

Plugin Details

Severity: Medium

ID: 66842

File Name: php_5_3_26.nasl

Version: 1.16

Type: remote

Family: CGI abuses

Published: 2013/06/07

Modified: 2018/09/17

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-4635

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2013/06/06

Vulnerability Publication Date: 2013/05/22

Reference Information

CVE: CVE-2013-2110, CVE-2013-4635

BID: 60411, 60731