PostgreSQL < 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 6815
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by multiple vulnerabilities.


Versions of PostgreSQL earlier than 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 are potentially affected by multiple vulnerabilities. It therefore is affected by the following vulnerabilities :

- A flaw in contrib/xml2's xslt_process can be used to read and write arbitrary files. (CVE-2012-3488)

- An xml_parse() DTD validation flaw can be used to read arbitrary files. (CVE-2012-3489)


Upgrade to PostgreSQL 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 6815

Family: Database

Published: 5/14/2013

Updated: 3/6/2019

Dependencies: 8704, 8705

Nessus ID: 63354

Risk Information


Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:postgresql:postgresql:*:*:*:*:*:*:*:*

Patch Publication Date: 8/17/2012

Vulnerability Publication Date: 8/17/2012

Reference Information

CVE: CVE-2012-3488, CVE-2012-3489

BID: 55072, 55074