PostgreSQL < 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6815

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

Versions of PostgreSQL earlier than 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 are potentially affected by multiple vulnerabilities. It therefore is affected by the following vulnerabilities :

- A flaw in contrib/xml2's xslt_process can be used to read and write arbitrary files. (CVE-2012-3488)

- An xml_parse() DTD validation flaw can be used to read arbitrary files. (CVE-2012-3489)

Solution

Upgrade to PostgreSQL 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 or later.

See Also

http://www.postgresql.org/about/news/1407

http://www.postgresql.org/docs/8.3/static/release-8-3-20.html

http://www.postgresql.org/docs/8.4/static/release-8-4-13.html

http://www.postgresql.org/docs/9.0/static/release-9-0-9.html

http://www.postgresql.org/docs/9.1/static/release-9-1-5.html

Plugin Details

Severity: Medium

ID: 6815

Family: Database

Published: 2013/05/14

Modified: 2018/09/16

Dependencies: 8704, 8705

Nessus ID: 63354

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 4.7

Temporal Score: 4.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2012/08/17

Vulnerability Publication Date: 2012/08/17

Reference Information

CVE: CVE-2012-3488, CVE-2012-3489

BID: 55072, 55074