PostgreSQL 8.3 < 8.3.20 / 8.4 < 8.4.13 / 9.0 < 9.0.9 / 9.1 < 9.1.5 Multiple Vulnerabilities

medium Nessus Plugin ID 63354
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 8.3.x prior to 8.3.20, 8.4.x prior to 8.4.13, 9.0.x prior to 9.0.9, or 9.1.x prior to 9.1.5. It therefore is potentially affected by multiple vulnerabilities :

- A flaw in contrib/xml2's xslt_process can be used to read and write arbitrary files. (CVE-2012-3488)

- An xml_parse() DTD validation flaw can be used to read arbitrary files. (CVE-2012-3489)


Upgrade to PostgreSQL 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 or later.

See Also

Plugin Details

Severity: Medium

ID: 63354

File Name: postgresql_20120817.nasl

Version: 1.14

Type: remote

Family: Databases

Published: 12/28/2012

Updated: 12/4/2019

Dependencies: postgresql_version.nbin

Risk Information

CVSS Score Source: CVE-2012-3488


Risk Factor: Medium

Score: 4


Risk Factor: Medium

Base Score: 4.9

Temporal Score: 3.6

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:N

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 8/17/2012

Vulnerability Publication Date: 8/17/2012

Reference Information

CVE: CVE-2012-3488, CVE-2012-3489

BID: 55072, 55074