CVE-2012-3489

medium
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

The xml_parse function in the libxml2 support in the core server component in PostgreSQL 8.3 before 8.3.20, 8.4 before 8.4.13, 9.0 before 9.0.9, and 9.1 before 9.1.5 allows remote authenticated users to determine the existence of arbitrary files or URLs, and possibly obtain file or URL content that triggers a parsing error, via an XML value that refers to (1) a DTD or (2) an entity, related to an XML External Entity (aka XXE) issue.

References

http://lists.apple.com/archives/security-announce/2013/Mar/msg00002.html

http://lists.opensuse.org/opensuse-updates/2012-09/msg00102.html

http://lists.opensuse.org/opensuse-updates/2012-10/msg00013.html

http://lists.opensuse.org/opensuse-updates/2012-10/msg00024.html

http://rhn.redhat.com/errata/RHSA-2012-1263.html

http://secunia.com/advisories/50635

http://secunia.com/advisories/50718

http://secunia.com/advisories/50859

http://secunia.com/advisories/50946

http://www.debian.org/security/2012/dsa-2534

http://www.mandriva.com/security/advisories?name=MDVSA-2012:139

http://www.postgresql.org/about/news/1407/

http://www.postgresql.org/docs/8.3/static/release-8-3-20.html

http://www.postgresql.org/docs/8.4/static/release-8-4-13.html

http://www.postgresql.org/docs/9.0/static/release-9-0-9.html

http://www.postgresql.org/docs/9.1/static/release-9-1-5.html

http://www.postgresql.org/support/security/

http://www.securityfocus.com/bid/55074

http://www.ubuntu.com/usn/USN-1542-1

https://blogs.oracle.com/sunsecurity/entry/multiple_vulnerabilities_in_postgresql2

https://bugzilla.redhat.com/show_bug.cgi?id=849173

Details

Source: MITRE

Published: 2012-10-03

Updated: 2013-10-10

Type: CWE-20

Risk Information

CVSS v2

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

Impact Score: 2.9

Exploitability Score: 8

Severity: MEDIUM

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:postgresql:postgresql:9.0:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.0.8:*:*:*:*:*:*:*

Configuration 2

OR

cpe:2.3:a:postgresql:postgresql:9.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:9.1.4:*:*:*:*:*:*:*

Configuration 3

OR

cpe:2.3:a:postgresql:postgresql:8.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.12:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.13:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.14:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.15:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.16:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.17:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.18:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.3.19:*:*:*:*:*:*:*

Configuration 4

OR

cpe:2.3:a:postgresql:postgresql:8.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.1:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.2:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.3:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.4:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.5:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.6:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.7:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.8:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.9:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.10:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.11:*:*:*:*:*:*:*

cpe:2.3:a:postgresql:postgresql:8.4.12:*:*:*:*:*:*:*

Tenable Plugins

View all (22 total)

IDNameProductFamilySeverity
83561SUSE SLED10 / SLES10 Security Update : PostgreSQL (SUSE-SU-2012:1336-1)NessusSuSE Local Security Checks
medium
74773openSUSE Security Update : postgresql (openSUSE-SU-2012:1299-1)NessusSuSE Local Security Checks
medium
74769openSUSE Security Update : postgresql / postgresql-libs (openSUSE-SU-2012:1288-1)NessusSuSE Local Security Checks
medium
74766openSUSE Security Update : postgresql / postgresql-libs (openSUSE-SU-2012:1251-1)NessusSuSE Local Security Checks
medium
69619Amazon Linux AMI : postgresql8 (ALAS-2012-129)NessusAmazon Linux Local Security Checks
medium
68620Oracle Linux 5 / 6 : postgresql / postgresql84 (ELSA-2012-1263)NessusOracle Linux Local Security Checks
medium
6815PostgreSQL < 8.3.20 / 8.4.13 / 9.0.9 / 9.1.5 Multiple VulnerabilitiesNessus Network MonitorDatabase
medium
65578Mac OS X Multiple Vulnerabilities (Security Update 2013-001)NessusMacOS X Local Security Checks
high
64216SuSE 11.1 Security Update : PostgreSQL (SAT Patch Number 6697)NessusSuSE Local Security Checks
medium
63354PostgreSQL 8.3 < 8.3.20 / 8.4 < 8.4.13 / 9.0 < 9.0.9 / 9.1 < 9.1.5 Multiple VulnerabilitiesNessusDatabases
medium
62801Mac OS X : OS X Server < 2.1.1 Multiple VulnerabilitiesNessusMacOS X Local Security Checks
medium
62545SuSE 10 Security Update : PostgreSQL (ZYPP Patch Number 8311)NessusSuSE Local Security Checks
medium
62380GLSA-201209-24 : PostgreSQL: Multiple vulnerabilitiesNessusGentoo Local Security Checks
medium
62108Scientific Linux Security Update : postgresql and postgresql84 on SL5.x, SL6.x i386/x86_64 (20120913)NessusScientific Linux Local Security Checks
medium
62088RHEL 5 / 6 : postgresql and postgresql84 (RHSA-2012:1263)NessusRed Hat Local Security Checks
medium
62083CentOS 5 / 6 : postgresql / postgresql84 (CESA-2012:1263)NessusCentOS Local Security Checks
medium
61984Mandriva Linux Security Advisory : postgresql (MDVSA-2012:139)NessusMandriva Local Security Checks
medium
61672Fedora 17 : postgresql-9.1.5-1.fc17 (2012-12165)NessusFedora Local Security Checks
medium
61671Fedora 16 : postgresql-9.1.5-1.fc16 (2012-12156)NessusFedora Local Security Checks
medium
61662Debian DSA-2534-1 : postgresql-8.4 - several vulnerabilitiesNessusDebian Local Security Checks
medium
61607Ubuntu 8.04 LTS / 10.04 LTS / 11.04 / 11.10 / 12.04 LTS : postgresql-8.3, postgresql-8.4, postgresql-9.1 vulnerabilities (USN-1542-1)NessusUbuntu Local Security Checks
medium
61586FreeBSD : databases/postgresql*-server -- multiple vulnerabilities (07234e78-e899-11e1-b38d-0023ae8e59f0)NessusFreeBSD Local Security Checks
medium