Apache 2.2 < 2.2.17 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6793

Synopsis

The remote web server is vulnerable to multiple attack vectors.

Description

Versions of Apache 2.2 earlier than 2.2.17 are potentially affected by multiple vulnerabilities :

- Errors exist in the bundled expat library that may allow an attacker to crash the server when a buffer is over-read when parsing an XML document. (CVE-2009-3720 and CVE-2009-3560)

- An error exists in the 'apr_brigade_split_line' function in the bundled APR-util library. Carefully timed bytes in requests result in gradual memory increases leading to a denial of service. (CVE-2010-1623)

Solution

Either ensure the affected module is not in use or upgrade to Apache version 2.2.17 or later.

See Also

http://www.nessus.org/u?1c39fa1c

http://httpd.apache.org/security/vulnerabilities_22.html

Plugin Details

Severity: Medium

ID: 6793

File Name: 6793.prm

Family: Web Servers

Published: 2013/05/07

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 50070

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.2

Patch Publication Date: 2010/10/19

Vulnerability Publication Date: 2009/01/17

Reference Information

CVE: CVE-2009-3560, CVE-2009-3720, CVE-2010-1623

BID: 37203, 36097, 43673

IAVA: 2012-A-0020