Apache 2.2.x < 2.2.17 Multiple Vulnerabilities

Medium Nessus Plugin ID 50070


The remote web server may be affected by several issues.


According to its banner, the version of Apache 2.2.x running on the remote host is prior to 2.2.17. It is, therefore, affected by the following vulnerabilities :

- Errors exist in the bundled expat library that may allow an attacker to crash the server when a buffer is over- read when parsing an XML document. (CVE-2009-3720 and CVE-2009-3560)

- An error exists in the 'apr_brigade_split_line' function in the bundled APR-util library. Carefully timed bytes in requests result in gradual memory increases leading to a denial of service. (CVE-2010-1623) Note that the remote web server may not actually be affected by these vulnerabilities. Nessus did not try to determine whether the affected modules are in use or to check for the issues themselves.


Upgrade to Apache version 2.2.17 or later. Alternatively, ensure that the affected modules are not in use.

See Also



Plugin Details

Severity: Medium

ID: 50070

File Name: apache_2_2_17.nasl

Version: $Revision: 1.14 $

Type: remote

Family: Web Servers

Published: 2010/10/20

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2010/10/19

Vulnerability Publication Date: 2009/01/17

Reference Information

CVE: CVE-2009-3560, CVE-2009-3720, CVE-2010-1623

BID: 37203, 36097, 43673

OSVDB: 59737, 60797, 68327

Secunia: 41701

CWE: 119