CVE-2009-3720

MEDIUM

Description

The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

References

http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?r1=1.13&r2=1.15&view=patch

http://expat.cvs.sourceforge.net/viewvc/expat/expat/lib/xmltok_impl.c?view=log

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051228.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051247.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051367.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051405.html

http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051442.html

http://lists.opensuse.org/opensuse-security-announce/2009-11/msg00004.html

http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00002.html

http://lists.opensuse.org/opensuse-security-announce/2010-06/msg00001.html

http://lists.opensuse.org/opensuse-security-announce/2010-08/msg00001.html

http://lists.vmware.com/pipermail/security-announce/2010/000082.html

http://mail.python.org/pipermail/expat-bugs/2009-January/002781.html

http://marc.info/?l=bugtraq&m=130168502603566&w=2

http://secunia.com/advisories/37324

http://secunia.com/advisories/37537

http://secunia.com/advisories/37925

http://secunia.com/advisories/38050

http://secunia.com/advisories/38231

http://secunia.com/advisories/38794

http://secunia.com/advisories/38832

http://secunia.com/advisories/38834

http://secunia.com/advisories/39478

http://secunia.com/advisories/41701

http://secunia.com/advisories/42326

http://secunia.com/advisories/42338

http://secunia.com/advisories/43300

http://slackware.com/security/viewer.php?l=slackware-security&y=2011&m=slackware-security.486026

http://sourceforge.net/tracker/index.php?func=detail&aid=1990430&group_id=10127&atid=110127

http://sunsolve.sun.com/search/document.do?assetkey=1-66-273630-1

http://svn.python.org/view?view=rev&revision=74429

http://www.mandriva.com/security/advisories?name=MDVSA-2009:211

http://www.mandriva.com/security/advisories?name=MDVSA-2009:212

http://www.mandriva.com/security/advisories?name=MDVSA-2009:215

http://www.mandriva.com/security/advisories?name=MDVSA-2009:216

http://www.mandriva.com/security/advisories?name=MDVSA-2009:217

http://www.mandriva.com/security/advisories?name=MDVSA-2009:218

http://www.mandriva.com/security/advisories?name=MDVSA-2009:219

http://www.mandriva.com/security/advisories?name=MDVSA-2009:220

http://www.openwall.com/lists/oss-security/2009/08/21/2

http://www.openwall.com/lists/oss-security/2009/08/26/3

http://www.openwall.com/lists/oss-security/2009/08/26/4

http://www.openwall.com/lists/oss-security/2009/08/27/6

http://www.openwall.com/lists/oss-security/2009/09/06/1

http://www.openwall.com/lists/oss-security/2009/10/22/5

http://www.openwall.com/lists/oss-security/2009/10/22/9

http://www.openwall.com/lists/oss-security/2009/10/23/2

http://www.openwall.com/lists/oss-security/2009/10/23/6

http://www.openwall.com/lists/oss-security/2009/10/26/3

http://www.openwall.com/lists/oss-security/2009/10/28/3

http://www.redhat.com/support/errata/RHSA-2010-0002.html

http://www.redhat.com/support/errata/RHSA-2011-0896.html

http://www.securitytracker.com/id?1023160

http://www.ubuntu.com/usn/USN-890-1

http://www.ubuntu.com/usn/USN-890-6

http://www.vupen.com/english/advisories/2010/0528

http://www.vupen.com/english/advisories/2010/0896

http://www.vupen.com/english/advisories/2010/1107

http://www.vupen.com/english/advisories/2010/3035

http://www.vupen.com/english/advisories/2010/3053

http://www.vupen.com/english/advisories/2010/3061

http://www.vupen.com/english/advisories/2011/0359

https://bugs.gentoo.org/show_bug.cgi?id=280615

https://bugzilla.redhat.com/show_bug.cgi?id=531697

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://lists.apache.org/thread.html/[email protected]%3Ccvs.httpd.apache.org%3E

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11019

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A12719

https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A7112

https://www.redhat.com/archives/fedora-package-announce/2009-December/msg00370.html

https://www.redhat.com/archives/fedora-package-announce/2009-December/msg00413.html

https://www.redhat.com/archives/fedora-package-announce/2009-December/msg01274.html

Details

Source: MITRE

Published: 2009-11-03

Updated: 2017-09-19

Risk Information

CVSS v2.0

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 10

Severity: MEDIUM