Oracle MySQL Server 5.1 < 5.1.63 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6653

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.63 and is, therefore, affected by the following vulnerabilities :

- Several errors exist related to 'GIS Extension' and 'Server Optimizer' components that can allow denial of service attacks. (CVE-2012-0540, CVE-2012-1689, CVE-2012-1734)

- A security bypass vulnerability exists that occurs due to improper casting during user login sessions. (Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order index that can lead to application crashes. (Bug #59387 / CVE-2012-2749

Solution

Upgrade to MySQL Server 5.1.63 later

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-1-63.html

http://seclists.org/oss-sec/2012/q2/493

Plugin Details

Severity: High

ID: 6653

Family: Database

Published: 2012/07/13

Modified: 2016/01/15

Dependencies: 8914

Nessus ID: 59448, 61393

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2012/05/07

Vulnerability Publication Date: 2012/06/11

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2012-0540, CVE-2012-1689, CVE-2012-1734, CVE-2012-2122, CVE-2012-2749

BID: 53911, 54540, 54551, 54547, 55120