MySQL 5.1 < 5.1.63 Multiple Vulnerabilities

Medium Nessus Plugin ID 59448

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.63 and is, therefore, affected by multiple vulnerabilities :

- Several errors exist related to 'GIS Extension' and 'Server Optimizer' components that can allow denial of service attacks. (CVE-2012-0540, CVE-2012-1689, CVE-2012-1734)

- A security bypass vulnerability exists that occurs due to improper casting during user login sessions.
(Bug #64884 / CVE-2012-2122)

- An error exists related to key length and sort order index that can lead to application crashes.
(Bug #59387 / CVE-2012-2749)

Solution

Upgrade to MySQL version 5.1.63 or later.

See Also

https://seclists.org/oss-sec/2012/q2/493

http://dev.mysql.com/doc/refman/5.1/en/news-5-1-63.html

http://www.nessus.org/u?6d4671b2

Plugin Details

Severity: Medium

ID: 59448

File Name: mysql_5_1_63.nasl

Version: 1.18

Type: remote

Family: Databases

Published: 2012/06/11

Updated: 2019/12/04

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2012-2122

CVSS v2.0

Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/05/07

Vulnerability Publication Date: 2012/06/11

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2012-0540, CVE-2012-1689, CVE-2012-1734, CVE-2012-2122, CVE-2012-2749

BID: 53911, 54540, 54547, 54551, 55120

EDB-ID: 19092