Google Chrome < 22.0.1229.92 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 6600

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

Versions of Google Chrome earlier than 22.0.1229.92 are potentially affected by the following vulnerabilities :

- An unspecified error exists related to Skia text rendering can cause the application to crash. (CVE-2012-2900)

- A race condition exists related to audio device handling. (CVE-2012-5108)

- Out-of-bounds read errors exist related to 'ICU' regular expressions and the compositor. (CVE-2012-5109, CVE-2012-5110)

- The 'Pepper' plugins are missing crash monitoring. (CVE-2012-5111)

Successful exploitation of any of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.

Solution

Upgrade to Google Chrome 22.0.1229.92 or later.

See Also

http://www.nessus.org/u?8ba40430

Plugin Details

Severity: High

ID: 6600

Family: Web Clients

Published: 2012/10/12

Modified: 2016/12/06

Dependencies: 1735, 8314

Nessus ID: 62518

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Patch Publication Date: 2012/10/08

Vulnerability Publication Date: 2012/10/08

Reference Information

CVE: CVE-2012-2900, CVE-2012-5108, CVE-2012-5109, CVE-2012-5110, CVE-2012-5111

BID: 55830