Google Chrome < 22.0.1229.92 Multiple Vulnerabilities

Medium Nessus Plugin ID 62518


The remote host contains a web browser that is affected by multiple vulnerabilities.


The version of Google Chrome installed on the remote host is earlier than 22.0.1229.92 and is, therefore, affected by the following vulnerabilities :

- An unspecified error exists related to Skia text rendering can cause the application to crash.

- A race condition exists related to audio device handling. (CVE-2012-5108)

- Out-of-bounds read errors exist related to 'ICU' regular expressions and the compositor.
(CVE-2012-5109, CVE-2012-5110)

- The 'Pepper' plugins are missing crash monitoring.

Successful exploitation of any of these issues could lead to an application crash or even allow arbitrary code execution, subject to the user's privileges.


Upgrade to Google Chrome 22.0.1229.92 or later.

See Also

Plugin Details

Severity: Medium

ID: 62518

File Name: google_chrome_22_0_1229_92.nasl

Version: $Revision: 1.6 $

Type: local

Agent: windows

Family: Windows

Published: 2012/10/12

Modified: 2016/05/16

Dependencies: 34196

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/10/08

Vulnerability Publication Date: 2012/10/08

Reference Information

CVE: CVE-2012-2900, CVE-2012-5108, CVE-2012-5109, CVE-2012-5110, CVE-2012-5111

BID: 55830

OSVDB: 86119, 86120, 86121, 86122, 86123