Flash Player <= 11.4.402.264 Multiple Vulnerabilities (APSB12-19)

High Nessus Network Monitor Plugin ID 6555

Synopsis

The remote host contains a browser plugin that is affected by multiple vulnerabilities

Description

Versions of Flash Player equal to or earlier than 11.4.402.264 are affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to code execution. (CVE-2012-4163, CVE-2012-4164, CVE-2012-4165, CVE-2012-4166)
- An integer overflow vulnerability exists that could lead to code execution. (CVE-2012-4167)
- A cross-domain information leak vulnerability exists. (CVE-2012-4168)
- An integer overflow condition affects the Matrix3D class. The copyRawDataTo method in the Matrix3D class fails to properly sanitize user-supplied input resulting in an integer overflow. With a specially crafted argument, a context-dependent attacker can potentially execute arbitrary code. (CVE-2012-5054)

Solution

Upgrade to Flash Player 11.4.402.265 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb12-19.html

Plugin Details

Severity: High

ID: 6555

File Name: 6555.prm

Family: Web Clients

Published: 2011/08/28

Modified: 2016/11/23

Dependencies: 5783

Nessus ID: 61622, 61623

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2012/08/21

Vulnerability Publication Date: 2012/08/21

Reference Information

CVE: CVE-2012-4163, CVE-2012-4164, CVE-2012-4165, CVE-2012-4167, CVE-2012-4168, CVE-2012-4171, CVE-2012-5054

BID: 55365, 56191, 55691