Flash Player for Mac <= / 11.4.402.264 Code Execution (APSB12-19)

High Nessus Plugin ID 61623


The remote Mac OS X host has a browser plugin that is affected by a remote code execution vulnerability.


According to its version, the instance of Flash Player installed on the remote Mac OS host is 11.x equal to or earlier than 11.4.402.264, or 10.x equal to or earlier than It is, therefore, potentially affected by multiple vulnerabilities :

- Multiple memory corruption vulnerabilities could lead to code execution. (CVE-2012-4163, CVE-2012-4164, CVE-2012-4165)

- An integer overflow vulnerability exists that could lead to code execution. (CVE-2012-4167)

- A cross-domain information leak vulnerability exists.

- A crash can be caused by a logic error involving multiple dialogs in Firefox. (CVE-2012-4171)

- A Matrix3D integer overflow vulnerability could lead to code execution. (CVE-2012-5054)


Upgrade to Adobe Flash Player version, 11.4.402.265 or later.

See Also



Plugin Details

Severity: High

ID: 61623

File Name: macosx_flash_player_11_4_402_265.nasl

Version: $Revision: 1.15 $

Type: local

Agent: macosx

Published: 2012/08/22

Modified: 2016/05/20

Dependencies: 53914

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/08/21

Vulnerability Publication Date: 2012/08/21

Reference Information

CVE: CVE-2012-4163, CVE-2012-4164, CVE-2012-4165, CVE-2012-4167, CVE-2012-4168, CVE-2012-4171, CVE-2012-5054

BID: 55365, 55691

OSVDB: 84789, 84790, 84791, 84792, 84793, 84794, 85260, 85786