Flash Player <= 10.3.183.22 / 11.4.402.264 Multiple Vulnerabilities (APSB12-19)
High Nessus Plugin ID 61622
SynopsisThe remote Windows host has a browser plugin that is affected by multiple vulnerabilities.
DescriptionAccording to its version, the instance of Flash Player installed on the remote Windows host is 11.x equal to or earlier than 11.4.402.264, or 10.x equal to or earlier than 10.3.183.22. It is, therefore, potentially affected by multiple vulnerabilities :
- Multiple memory corruption vulnerabilities could lead to code execution. (CVE-2012-4163, CVE-2012-4164, CVE-2012-4165)
- An integer overflow vulnerability exists that could lead to code execution. (CVE-2012-4167)
- A cross-domain information leak vulnerability exists.
- A crash can be caused by a logic error involving multiple dialogs in Firefox. (CVE-2012-4171)
- A Matrix3D integer overflow vulnerability could lead to code execution. (CVE-2012-5054)
SolutionUpgrade to Adobe Flash Player version 10.3.183.23, 11.4.402.265 or later, or Google Chrome PepperFlash 220.127.116.11 or later.