Oracle MySQL Server 5.5 < 5.5.22 Multiple Unspecified Vulnerabilities

high Nessus Network Monitor Plugin ID 6491

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

Versions of MySQL 5.5 earlier than 5.5.22 are outdated and thus affected by the following vulnerabilities :

- An error exists related to the included yaSSL component that could allow arbitrary code execution. (CVE-2012-0882)
- Errors exist related to 'Server Optimizer', 'Server DML', 'Partition' and, in combination with InnoDB, 'HANDLER READ NEXT' that could allow denial of service attacks. (CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102)

Solution

Upgrade to MySQL Server 5.5.22 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-22.html

Plugin Details

Severity: High

ID: 6491

Family: Database

Published: 5/25/2012

Updated: 3/6/2019

Nessus ID: 58661

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Patch Publication Date: 3/21/2012

Vulnerability Publication Date: 3/21/2012

Reference Information

CVE: CVE-2012-1688, CVE-2012-1690, CVE-2012-1703, CVE-2012-1697

BID: 52931, 53058, 53067, 53074, 53064