MySQL 5.5 < 5.5.22 Multiple Vulnerabilities

High Nessus Plugin ID 58661

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL 5.5 installed on the remote host is earlier than 5.5.22. It is, therefore, affected by the following vulnerabilities :

- An error exists related to the included yaSSL component that could allow arbitrary code execution.
(CVE-2012-0882)

- Errors exist related to 'Server Optimizer', 'Server DML', 'Partition' and, in combination with InnoDB, 'HANDLER READ NEXT' that could allow denial of service attacks. (CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102)

Solution

Upgrade to MySQL version 5.5.22 or later.

See Also

http://dev.mysql.com/doc/refman/5.5/en/news-5-5-22.html

http://www.nessus.org/u?4225df87

https://www.openwall.com/lists/oss-security/2012/02/24/2

Plugin Details

Severity: High

ID: 58661

File Name: mysql_5_5_22.nasl

Version: 1.15

Type: remote

Family: Databases

Published: 2012/04/11

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/03/21

Vulnerability Publication Date: 2012/03/21

Reference Information

CVE: CVE-2012-0882, CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102

BID: 51925, 52931, 53058, 53064, 53067, 53074