MySQL 5.5 < 5.5.22 Multiple Vulnerabilities

high Nessus Plugin ID 58661
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is affected by multiple vulnerabilities.


The version of MySQL 5.5 installed on the remote host is earlier than 5.5.22. It is, therefore, affected by the following vulnerabilities :

- An error exists related to the included yaSSL component that could allow arbitrary code execution.

- Errors exist related to 'Server Optimizer', 'Server DML', 'Partition' and, in combination with InnoDB, 'HANDLER READ NEXT' that could allow denial of service attacks. (CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102)


Upgrade to MySQL version 5.5.22 or later.

See Also

Plugin Details

Severity: High

ID: 58661

File Name: mysql_5_5_22.nasl

Version: 1.15

Type: remote

Family: Databases

Published: 4/11/2012

Updated: 11/15/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/21/2012

Vulnerability Publication Date: 3/21/2012

Reference Information

CVE: CVE-2012-0882, CVE-2012-1688, CVE-2012-1690, CVE-2012-1697, CVE-2012-1703, CVE-2012-2102

BID: 51925, 52931, 53058, 53064, 53067, 53074