PostgreSQL < 9.1.3 / 9.0.7 / 8.4.11 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 6337


The remote database server is vulnerable to multiple attack vectors.


Versions of PostgreSQL earlier than 9.1.3, 9.0.7, 8.4.11 and are potentially affected by the following vulnerabilities :

- Permissions on a function called by a trigger are not properly checked. (CVE-2012-0866)

- SSL certificate name checks are truncated to 32 characters, allowing connection spoofing under some circumstances when using third party certificates. (CVE-2012-0867)

- Line breaks in object names can be exploited to execute arbitrary SQL when reloading a pg_dump file. (CVE-2012-0868)


Upgrade to PostgreSQL 8.4.11, 9.0.7, 9.1.3, or later.

See Also

Plugin Details

Severity: Medium

ID: 6337

File Name: 6337.prm

Family: Database

Published: 2012/02/28

Modified: 2016/01/21

Dependencies: 8704, 8705

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.5


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2012/02/27

Vulnerability Publication Date: 2012/02/27

Reference Information

CVE: CVE-2012-0866, CVE-2012-0867, CVE-2012-0868

BID: 52188