PostgreSQL 8.3 < 8.3.18 Multiple Vulnerabilities

high Nessus Plugin ID 63355
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 8.3.x prior to 8.3.18, and is, therefore, potentially affected by multiple vulnerabilities :

- Permissions on a function called by a trigger are not properly checked. (CVE-2012-0866)
- Line breaks in object names can be exploited to execute arbitrary SQL commands when reloading a pg_dump file.
(CVE-2012-0868)

Solution

Upgrade to PostgreSQL 8.3.18 or later.

See Also

http://www.postgresql.org/about/news/1377/

https://www.postgresql.org/docs/8.3/release-8-3-18.html

Plugin Details

Severity: High

ID: 63355

File Name: postgresql_8318.nasl

Version: 1.8

Type: local

Family: Databases

Published: 12/28/2012

Updated: 11/15/2018

Dependencies: postgresql_version.nbin

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Ease: No known exploits are available

Patch Publication Date: 2/27/2012

Vulnerability Publication Date: 2/27/2012

Reference Information

CVE: CVE-2012-0866, CVE-2012-0868

BID: 52188