PostgreSQL 8.3 < 8.3.18 Multiple Vulnerabilities

Medium Nessus Plugin ID 63355


The remote database server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 8.3.x prior to 8.3.18, and is, therefore, potentially affected by multiple vulnerabilities :

- Permissions on a function called by a trigger are not properly checked. (CVE-2012-0866)
- Line breaks in object names can be exploited to execute arbitrary SQL commands when reloading a pg_dump file.


Upgrade to PostgreSQL 8.3.18 or later.

See Also

Plugin Details

Severity: Medium

ID: 63355

File Name: postgresql_8318.nasl

Version: 1.8

Type: local

Family: Databases

Published: 2012/12/28

Updated: 2018/11/15

Dependencies: 63346

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/02/27

Vulnerability Publication Date: 2012/02/27

Reference Information

CVE: CVE-2012-0866, CVE-2012-0868

BID: 52188