PHP < 5.2.13 / 5.3.x < 5.3.2 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5346

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is earlier than 5.3.2 / 5.2.13. Such versions are potentially affected by multiple vulnerabilities :

- A safe_mode validation issue inside 'tempnam()' when the directory path does not end with a '/'.

- A possible open_basedir/safe_mode bypass in the session extension.

Solution

Upgrade to PHP version 5.3.2 / 5.2.13 or later.

See Also

http://securityreason.com/securityalert/7008

http://www.php.net/releases/5_3_2.php

http://www.php.net/releases/5_2_13.php

http://www.php.net/ChangeLog-5.php#5.3.2

http://www.php.net/ChangeLog-5.php#5.2.13

Plugin Details

Severity: High

ID: 5346

File Name: 5346.prm

Family: Web Servers

Published: 2010/02/26

Modified: 2016/01/15

Dependencies: 8682, 8728

Nessus ID: 44921

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2010/02/25

Vulnerability Publication Date: 2010/02/26

Reference Information

CVE: CVE-2010-1128, CVE-2010-1129, CVE-2010-1130

BID: 38430, 38431, 38182