PHP < 5.3.2 / 5.2.13 Multiple Vulnerabilities

medium Nessus Plugin ID 44921


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP installed on the remote host is older than 5.3.2 / 5.2.13. Such versions may be affected by several security issues :

- Directory paths not ending with '/' may not be correctly validated inside 'tempnam()' in 'safe_mode' configuration.

- It may be possible to bypass the 'open_basedir'/ 'safe_mode' configuration restrictions due to an error in session extensions.

- An unspecified vulnerability affects the LCG entropy.


Upgrade to PHP version 5.3.2 / 5.2.13 or later.

See Also

Plugin Details

Severity: Medium

ID: 44921

File Name: php_5_2_13.nasl

Version: 1.17

Type: remote

Family: CGI abuses

Published: 2/26/2010

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 5.3


Risk Factor: Medium

Base Score: 6.4

Temporal Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 2/25/2010

Vulnerability Publication Date: 2/11/2010

Reference Information

CVE: CVE-2010-1128, CVE-2010-1129, CVE-2010-1130

BID: 38182, 38430, 38431

SECUNIA: 38708