PHP 5.x < 5.2.8 magic_quotes_gpc Security Bypass

High Nessus Network Monitor Plugin ID 4784

Synopsis

The remote web server uses a version of PHP that is affected by a security bypass weakness.

Description

According to its banner, the version of PHP installed on the remote host is 5.2.7. This version introduced a regression with regard to 'magic_quotes' functionality due to an incorrect fix to the filter extension. As a result, the 'magic_quotes_gpc' setting remains off even if it is set to on.

Solution

Upgrade to version 5.2.8 or higher.

See Also

http://www.php.net/releases/5_2_8.php

http://bugs.php.net/42718

Plugin Details

Severity: High

ID: 4784

Family: Web Servers

Published: 2008/12/10

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 35067

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2008/12/05

Vulnerability Publication Date: 2008/12/05

Reference Information

CVE: CVE-2008-5844

BID: 32673